[Quickbase US Status] Notice: Service Performance Degraded (Unplanned)

Incident
04/08/2023, 12:00pm EDT

[Quickbase US Status] Notice: Service Performance Degraded (Unplanned)

Status: closed
Start: 04/03/2023, 09:04am EDT
End: 04/03/2023, 10:10am EDT
Duration: 1 hour 6 minutes
Affected Components:
Quickbase Service - US Region Quickbase Audit Logs - US Region Quickbase Automations - US Region Quickbase Billing - US Region Quickbase Pipelines - US Region Quickbase Platform Analytics - US Region Quickbase RESTful APIs - US Region Quickbase Sync - US Region Quickbase Webhooks - US Region
Update

04/03/2023, 09:04am EDT

04/03/2023, 09:04am EDT

As of 9:04 AM Eastern US Time, some requests to the Quickbase US platform for less than 1% of applications may be slow.  We are working to resolve the performance of those applications.  We will post an update within 30 minutes.

Update

04/03/2023, 09:20am EDT

04/03/2023, 09:20am EDT

We are continuing to work to resolve this issue.  We will post an update within 1 hour.

Resolved

04/03/2023, 10:10am EDT

04/03/2023, 10:10am EDT

As of 10:10 AM Eastern US Time, the Quickbase US platform is performing normally.

This incident is closed.

Root Cause

04/08/2023, 12:00pm EDT

04/08/2023, 12:00pm EDT

During a restart of the Quickbase platform, applications are loaded into our fleet of run-time engines using criteria that attempt to reduce the chance of one run-time engine becoming overloaded.  In rare instances, we need to manually intercede to properly balance the applications.  In this incident, one of the run-time engines became overloaded so we moved some of the applications to other run-time engines.  To learn more about how the Quickbase platform hosts your applications to provide optimal performance and scalability, see the Quickbase Platform Evaluation Guide.

See the Root Cause section of this post for more details related to this incident.