[Quickbase US Status] Notice: Data Center Switch (Planned) - Down Time

Maintenance
12/09/2023, 02:10am EST

[Quickbase US Status] Notice: Data Center Switch (Planned) - Down Time

Status: closed
Start: 12/09/2023, 12:10am EST
End: 12/09/2023, 02:10am EST
Duration: 2 hours
Affected Components:
Quickbase Service - US Region Quickbase Audit Logs - US Region Quickbase Automations - US Region Quickbase Billing - US Region Quickbase Pipelines - US Region Quickbase Platform Analytics - US Region Quickbase RESTful APIs - US Region Quickbase Sync - US Region Quickbase Webhooks - US Region
Update

12/09/2023, 12:10am EST

12/09/2023, 12:10am EST

We are continuing our year long plan to transition parts of the US Instance of the Quickbase platform ("Quickbase US") between our existing hosting locations, and to introduce a new hosting location in December of 2023 and early Q1 of 2024.  This hosting transition is being accomplished using planned down time similar to the data center switches we typically do 2-3 times per year.

No action will be needed by customers aside from being aware of the planned down time as it is announced during 2023 or 2024.

A full explanation of the hosting transition, and a visual depiction of the milestones are linked to in this Quickbase Community post.

On the weekend of December 9-10, and on either Saturday, January 20 or Saturday, January 27, we will have the following planned down time to perform data center switches as the next customer facing steps of the hosting transition. All times shown are Eastern US Time.

Quickbase US will be unavailable during this maintenance

  • Saturday, December 9, 12:10 AM to 3:00 AM - Switch the active location of the Core Cluster Components of Quickbase US from Flexential-Colorado to AWS-Ohio.
    • [CONDITIONAL] Only if we detect any issues during the weekend of December 9-10, then planned down time as follows:
      • Sunday, December 10, between 6:10 AM and 8:00 AM - Switch the active location of the Core Cluster Components of Quickbase US from AWS-Ohio to Flexential-Colorado.

  • If we do NOT detect any issues during the weekend of December 9-10, then we will continue to run the active location in AWS-Ohio for 6-7 weeks until planned down time as follows:
    • Either Saturday, January 20, or Saturday, January 27, 12:10 AM to 3:00 AM - Switch the active location of the Core Cluster Components of Quickbase US from AWS-Ohio to AWS-Oregon.
    • The exact date for the switch to AWS-Oregon will be determined after January 2 and announced to customers via direct e-mail and a post on the Quickbase service page.
  • If we stay in AWS-Ohio after December 10, and we detect any issues between December 10 and either January 20 or 27 that we cannot correct, we will use unplanned down time to switch the Core Cluster Components for Quickbase US to run active in Flexential-Colorado or AWS-Oregon, depending on the judgement of our Site Reliability Engineering (SRE) team. We will strive to minimize the duration of any unplanned down time and, if possible, perform the switch during non-US business hours. The typical duration for switching the active location to another location ranges from 2-3 hours.
  • The planned down time periods above were chosen because they are historically the lowest point of utilization of the platform by our customers.

If you have any questions, please contact your Quickbase Account Team.

Resolved

12/09/2023, 02:10am EST

12/09/2023, 02:10am EST

The Quickbase-US platform was open to customers with the active location being AWS-Ohio at 2:00 AM Eastern US Time.  By 2:10 AM, performance of the platform was normal.

We have completed our verification of the platform in this location.

This incident is closed.