[Quickbase US Status] Notice: Service Functionality Degraded (Unplanned)

Incident
04/19/2024, 08:24am EDT

[Quickbase US Status] Notice: Service Functionality Degraded (Unplanned)

Status: closed
Start: 04/17/2024, 09:39am EDT
End: 04/17/2024, 03:10pm EDT
Duration: 5 hours 31 minutes
Affected Components:
Quickbase Service - US Region Quickbase Audit Logs - US Region Quickbase Automations - US Region Quickbase Billing - US Region Quickbase Pipelines - US Region Quickbase Platform Analytics - US Region Quickbase RESTful APIs - US Region Quickbase Sync - US Region Quickbase Webhooks - US Region
Update

04/17/2024, 09:39am EDT

04/17/2024, 09:39am EDT

Starting around 9:39 AM Eastern US Time, requests to the following services are experiencing performance degradation: Data Analyzer, Performance Optimizer, Performance Insights and Data Scanner.  

Update

04/17/2024, 02:14pm EDT

04/17/2024, 02:14pm EDT

We have identified the issue and are working on a resolution as soon as possible. 

Resolved

04/17/2024, 03:10pm EDT

04/17/2024, 03:10pm EDT

We have deployed a fix for this issue. 

This incident is closed.

We will provide a root cause once it's available.


Root Cause

04/19/2024, 08:24am EDT

04/19/2024, 08:24am EDT

A configuration change unexpectedly prevented certain services from connecting to the Quickbase platform correctly.  Due to this change, users interacting with our Data Analyzer (beta), Data Scanner, Performance Optimizer and Performance Insights services did not receive complete results during the duration of the incident.  We reverted the configuration change to ultimately fix the issue.

We apologize for any inconvenience this issue may have caused.  We have implemented additional monitoring and enhanced our deployment processes to prevent this issue from reoccurring.