[Quickbase Status] Notice: Quickbase Community Unavailable (Unplanned) - Down Time

Incident
05/10/2024, 09:15am EDT

[Quickbase Status] Notice: Quickbase Community Unavailable (Unplanned) - Down Time

Status: closed
Start: 05/07/2024, 08:45am EDT
End: 05/07/2024, 09:25am EDT
Duration: 40 minutes
Affected Components:
Quickbase Community
Update

05/07/2024, 08:45am EDT

05/07/2024, 08:45am EDT

Our Quickbase Community forum, community.quickbase.com, was reported unavailable. Actions to review and remediate are underway.

Resolved

05/07/2024, 09:25am EDT

05/07/2024, 09:25am EDT

As of 9:25 AM Eastern US Time, Quickbase Community is functioning normally.

This incident is closed.

Root Cause

05/10/2024, 09:15am EDT

05/10/2024, 09:15am EDT

The vendor that hosts the Quickbase Community site initiated a maintenance update starting at 8:45 AM Eastern US Time on Tuesday, May 7.  The vendor did not notify Quickbase staff of this update ahead of time.  The update caused access tokens to be invalidated and new access tokens were not generated.  As a result, requests could not be successfully processed and the compute resources supporting the site were overwhelmed.  The vendor was alerted to the problem via their monitoring system.  They responded by restarting the Quickbase Community site.  By 9:25 AM Eastern US Time, it was working normally.

In the future, the vendor will only do these updates during maintenance windows communicated to Quickbase staff ahead of time.  They are also working at a technical level to enhance the ability of the Quickbase Community site to auto-recover from such scenarios (token invalidations during an update).