[Quickbase US Status] Notice: Hosting Location Switch (Emergency) - Down Time

Maintenance
07/02/2024, 12:03am EDT

[Quickbase US Status] Notice: Hosting Location Switch (Emergency) - Down Time

Status: closed
Start: 07/01/2024, 11:10pm EDT
End: 07/02/2024, 12:03am EDT
Duration: 53 minutes
Affected Components:
Quickbase Service - US Region Quickbase Audit Logs - US Region Quickbase Automations - US Region Quickbase Billing - US Region Quickbase Pipelines - US Region Quickbase Platform Analytics - US Region Quickbase RESTful APIs - US Region Quickbase Sync - US Region Quickbase Webhooks - US Region
Update

07/01/2024, 11:10pm EDT

07/01/2024, 11:10pm EDT

The Quickbase team will be performing emergency maintenance to switch the active location of Quickbase US from AWS-Oregon to AWS-Ohio.

Quickbase US will be down during this emergency maintenance.

This maintenance window will be:  Monday, July 1, 11:10 PM to Tuesday, July 2, 2:00 AM Eastern US Time

As with all our hosting location switches, there is nothing customers need to do aside from maintaining awareness of the planned down time.

Please read on if you want more information about this maintenance.

Emergency Down Time for Quickbase US

The production US Instance of the Quickbase platform (“Quickbase US”) is currently built on top of two cloud hosting providers: Amazon Web Services (AWS), and Google Cloud Platform (GCP).  All platform functionality except pipelines runs in AWS.  The primary platform services running in AWS are referred to as the “Core Cluster Components” and include the Quickbase Runtime Engine and proprietary in-memory database, as well as Application Data, Application Schema, Realms, Accounts, and Users.  If interested, you can read more about the Core Cluster Components in the Quickbase Platform Evaluation Guide.

To ensure the availability of the Quickbase US platform in AWS, Quickbase uses two geographically diverse locations: US-West-2 ("AWS-Oregon") and US-East-2 ("AWS-Ohio").  Quickbase can run actively in only one location at a time with the other location running in standby mode.  We periodically need to switch between the two AWS locations as part of our normal disaster recovery plan validation process.  Switching between AWS locations allows us to ensure that Quickbase’s disaster recovery plan is tested and working properly should there ever be a real disaster.  Since January 27, 2024, the Core Cluster Components for Quickbase US have been running actively in AWS-Oregon.  

The Quickbase US platform instances in both locations are always identical so there will be no change in Quickbase function or performance.  As with all our hosting location switches, there is nothing customers need to do aside from maintaining awareness of the planned down time.

The reason for this emergency down time is the disk storage supporting the Core Cluster Components does not presently have a redundant copy in AWS-Oregon following a hardware failure earlier today.  Although we have recreated the secondary disk storage and started data replication, it is not estimated to complete for over 60 hours.  To reduce the risk of unplanned down time for Quickbase US, the safest action is to move to AWS-Ohio where the disk storage supporting the Core Cluster Components is already in a fully redundant state.  We are planning to do the switch between Monday, July 1, 11:10 PM to Tuesday, July 2, 2:00 AM Eastern US Time.  Quickbase US will be unavailable during this maintenance period.

Resolved

07/02/2024, 12:03am EDT

07/02/2024, 12:03am EDT

Quickbase US was available as of 11:54 PM Eastern US Time.  It is normal for performance to be slower than normal for a few minutes following a location switch.  As of 12:03 AM Eastern US Time, Quickbase US performance returned to normal.

This incident is closed.