[Quickbase US Status] Notice: Service Performance Degraded (Unplanned)

Incident
01/22/2025, 06:30am EST

[Quickbase US Status] Notice: Service Performance Degraded (Unplanned)

Status: closed
Start: 01/22/2025, 05:11am EST
End: 01/22/2025, 05:28am EST
Duration: 17 minutes
Affected Components:
Quickbase Service - US Region Quickbase Audit Logs - US Region Quickbase Automations - US Region Quickbase Billing - US Region Quickbase Pipelines - US Region Quickbase Platform Analytics - US Region Quickbase RESTful APIs - US Region Quickbase Sync - US Region Quickbase Webhooks - US Region
Update

01/22/2025, 05:11am EST

01/22/2025, 05:11am EST

Between 5:11 AM and 5:28 AM Eastern US Time, about 6% of requests to Quickbase US may have timed out or returned errors for a period lasting anywhere between a few seconds and 17 minutes.

Resolved

01/22/2025, 05:28am EST

01/22/2025, 05:28am EST

As of 5:28 AM Eastern US Time, performance of Quickbase US is normal.

This incident is closed.

Root Cause

01/22/2025, 06:30am EST

01/22/2025, 06:30am EST

The root cause of this incident was hardware failure of the servers on which the impacted applications were running.  In the case of a hardware failure, the Quickbase platform is designed to automatically move applications to healthy servers and that happened for the majority of impacted applications in this case.  Certain applications are configured to only run on certain servers and those applications were unavailable for the full 17 minute duration of this incident.

We have maintenance scheduled for January 25th which will change this behavior so that all applications that were running on a failed server will automatically move to a healthy server.