[Quickbase Status] Notice: Quickbase Company Website (www.quickbase.com) Service Functionality Degraded (Planned)

Maintenance
03/13/2025, 12:43pm EDT

[Quickbase Status] Notice: Quickbase Company Website (www.quickbase.com) Service Functionality Degraded (Planned)

Status: closed
Start: 03/13/2025, 12:30pm EDT
End: 03/13/2025, 12:43pm EDT
Duration: 13 minutes
Affected Components:
Quickbase Company Website
Update

03/13/2025, 12:30pm EDT

03/13/2025, 12:30pm EDT

On Thursday, March 13, 2025 between 12:30 PM and 1:30 PM Eastern US Time, the Quickbase Company Website (www.quickbase.com) will be undergoing maintenance to upgrade the infrastructure on which the site runs.  At times during this upgrade, users may notice slower response times, or errors.  If you receive an error, please refresh the page.

This maintenance has no impact on use of the Quickbase platform by our customers.

Resolved

03/13/2025, 12:43pm EDT

03/13/2025, 12:43pm EDT

This incident is closed.