[Quickbase Status] Notice: Service Performance Degraded (Unplanned)

Incident
03/17/2025, 08:50pm EDT

[Quickbase Status] Notice: Service Performance Degraded (Unplanned)

Status: closed
Start: 03/16/2025, 02:45pm EDT
End: 03/17/2025, 08:50pm EDT
Duration: 1 day 6 hours 5 minutes
Affected Components:
Quickbase Service - US Region Quickbase Billing - US Region
Update

03/16/2025, 02:45pm EDT

03/16/2025, 02:45pm EDT

Starting March 16, 2025, customers may get an error when clicking the Manage Billing button on the Admin Console page. We are actively investigating this issue and will provide an update as soon as we can.

Update

03/17/2025, 01:11am EDT

03/17/2025, 01:11am EDT

We continue to work with our vendor on this issue.  We will post another update as soon as we have one.

Update

03/17/2025, 09:38am EDT

03/17/2025, 09:38am EDT

We continue to work with the vendor on this issue and have escalated with them. We will post another update as soon as we have one.

Update

03/17/2025, 05:00pm EDT

03/17/2025, 05:00pm EDT

The vendor found the source of the problem and is working on a fix.  There is no estimate yet on when the fix will be deployed.  We will post another update as soon as we get a definitive deployment time for the fix from the vendor.

Resolved

03/17/2025, 08:50pm EDT

03/17/2025, 08:50pm EDT

Our vendor corrected the issue at 8:04 PM ET. We will post a root cause when it is obtained.