[Quickbase US Status] Notice: Product Upgrade (Planned) - No Down Time

Maintenance
03/19/2025, 07:45am EDT

[Quickbase US Status] Notice: Product Upgrade (Planned) - No Down Time

Status: closed
Start: 03/19/2025, 07:00am EDT
End: 03/19/2025, 07:45am EDT
Duration: 45 minutes
Affected Components:
Quickbase Service - US Region Quickbase Automations - US Region
Update

03/19/2025, 07:00am EDT

03/19/2025, 07:00am EDT

The Quickbase team will be performing maintenance to execute a minor upgrade of the Quickbase AI console and related features. 

This maintenance window will be Wednesday, March 19, 2025, between 7:00 AM to 8:00 AM Eastern US Time.

Users may encounter a generic error message when accessing the following services:

AI Smart Builder

Trial Experience - utilizing the AI Smart Builder

AI Recommended Reports

AI Console

Resolved

03/19/2025, 07:45am EDT

03/19/2025, 07:45am EDT

This incident is closed.