[Quickbase US Status] Notice: Product Upgrade (Planned) - No Down Time

Maintenance
03/25/2025, 06:27am EDT

[Quickbase US Status] Notice: Product Upgrade (Planned) - No Down Time

Status: closed
Start: 03/25/2025, 05:00am EDT
End: 03/25/2025, 06:27am EDT
Duration: 1 hour 27 minutes
Affected Components:
Quickbase Service - US Region Quickbase Pipelines - US Region
Update

03/25/2025, 05:00am EDT

03/25/2025, 05:00am EDT

The Quickbase team will be performing maintenance to execute a minor upgrade of the Quickbase Pipelines service.  Some Pipelines may experience a short delay during this maintenance.

This maintenance window will be: Tuesday, March 25, 2025, between 5:00 AM and 6:00 AM Eastern US Time.

Update

03/25/2025, 06:00am EDT

03/25/2025, 06:00am EDT

We are experiencing a delay in our deployment process beyond our previously posted time frame.  We are working to complete our deployment as soon as possible.

Resolved

03/25/2025, 06:27am EDT

03/25/2025, 06:27am EDT

We completed our deployment at 6:27 AM Eastern US Time.

This incident is closed.