[Quickbase US Status] Notice: Service Unavailable (Unplanned) - Down Time

Incident
03/22/2025, 09:56am EDT

[Quickbase US Status] Notice: Service Unavailable (Unplanned) - Down Time

Status: closed
Start: 03/22/2025, 09:11am EDT
End: 03/22/2025, 09:56am EDT
Duration: 45 minutes
Affected Components:
Quickbase Service - US Region Quickbase Audit Logs - US Region Quickbase Automations - US Region Quickbase Billing - US Region Quickbase Pipelines - US Region Quickbase Platform Analytics - US Region Quickbase RESTful APIs - US Region Quickbase Sync - US Region Quickbase Webhooks - US Region
Update

03/22/2025, 09:11am EDT

03/22/2025, 09:11am EDT

As of 9:11 AM Eastern US Time, the Quickbase US platform is unavailable.  We are actively working to restore service.  We will post another update by 9:45 AM.

Update

03/22/2025, 09:40am EDT

03/22/2025, 09:40am EDT

As of 9:40 AM Eastern US Time, Quickbase US is available.  However, performance will be slower than normal for up to 30 minutes.  We will post another update by 10:00 AM.

Update

03/22/2025, 09:55am EDT

03/22/2025, 09:55am EDT

As of 9:55 AM Eastern US Time, the Quickbase US platform is almost at normal performance.  We will post another update by 10:15 AM.

Resolved

03/22/2025, 09:56am EDT

03/22/2025, 09:56am EDT

As of 9:56 AM Eastern US Time, Quickbase US performance has returned to normal.

This incident is closed.

We will post a root cause once we have it.