[Quickbase Status] Notice: Service Performance Degraded (Unplanned)

Incident
04/07/2025, 07:06pm EDT

[Quickbase Status] Notice: Service Performance Degraded (Unplanned)

Status: closed
Start: 04/07/2025, 05:01pm EDT
End: 04/07/2025, 07:06pm EDT
Duration: 2 hours 5 minutes
Affected Components:
Quickbase Service - US Region Quickbase Platform Analytics - US Region
Update

04/07/2025, 05:01pm EDT

04/07/2025, 05:01pm EDT

We are currently investigating intermittent errors that may affect data loading in Platform Analytics for some customers.

Update

04/07/2025, 06:41pm EDT

04/07/2025, 06:41pm EDT

The vendor found the source of the problem and is implementing a fix. There is no estimate yet on when the fix will be completed.  We will post another update as soon as we get a confirmation of deployment completion from the vendor. Functionality may have returned for some customers.

Resolved

04/07/2025, 07:06pm EDT

04/07/2025, 07:06pm EDT

Our vendor confirmed that the fix was completed at 7:06 PM ET and that services were restored as of 6:40 PM ET. We will post a root cause when it is obtained.