[Quickbase EU Status] Notice: Service Performance Degraded (Planned) - No Down Time

Incident
04/23/2025, 07:56pm EDT

[Quickbase EU Status] Notice: Service Performance Degraded (Planned) - No Down Time

Status: closed
Start: 04/23/2025, 07:00pm EDT
End: 04/23/2025, 07:56pm EDT
Duration: 56 minutes
Affected Components:
Quickbase Service - EU Region Quickbase Audit Logs - EU Region Quickbase Billing - EU Region Quickbase Pipelines - EU Region Quickbase RESTful APIs - EU Region Quickbase Sync - EU Region Quickbase Webhooks - EU Region
Update

04/23/2025, 07:00pm EDT

04/23/2025, 07:00pm EDT

The Quickbase team will be performing maintenance to upgrade a storage system supporting the Quickbase EU platform.

For brief periods during this maintenance, customers may experience slower performance.

This maintenance window will be: Wednesday, April 23, 7:00 PM to 8:00 PM Eastern US Time

Please note that this maintenance will not impact the US Instance of the Quickbase platform.  Quickbase US and Quickbase EU are completely separate instances of the platform.

Resolved

04/23/2025, 07:56pm EDT

04/23/2025, 07:56pm EDT

This incident is closed.