[Quickbase Status] Notice: Service Functionality Degraded (Planned) - No Down Time

Maintenance
05/17/2025, 04:00am EDT

[Quickbase Status] Notice: Service Functionality Degraded (Planned) - No Down Time

Status: closed
Start: 05/16/2025, 10:00pm EDT
End: 05/17/2025, 04:00am EDT
Duration: 6 hours
Affected Components:
Quickbase Service - US Region Quickbase Service - EU Region Quickbase Billing - EU Region Quickbase Billing - US Region
Update

05/16/2025, 10:00pm EDT

05/16/2025, 10:00pm EDT

Quickbase uses a partner named Billing Platform to provide some billing related information and functionality for the Quickbase platform.  Billing Platform will be executing planned maintenance to update their platform.  During this maintenance, customers using either the US or EU instance of the Quickbase platform will be unable to use the "Manage Billing" button on the Admin Console page.  This includes the ability to pay an invoice.

This maintenance window will be: Friday, May 16, 2025, between 10:00 PM and 4:00 AM Eastern US Time.

Resolved

05/17/2025, 04:00am EDT

05/17/2025, 04:00am EDT

This incident is closed.