[Quickbase US Status] Notice: Service Functionality Degraded (Unplanned)

Incident
05/06/2025, 10:37am EDT

[Quickbase US Status] Notice: Service Functionality Degraded (Unplanned)

Status: closed
Start: 05/06/2025, 09:46am EDT
End: 05/06/2025, 10:37am EDT
Duration: 51 minutes
Affected Components:
Quickbase Service - US Region Quickbase Audit Logs - US Region Quickbase Automations - US Region Quickbase Billing - US Region Quickbase Pipelines - US Region Quickbase Platform Analytics - US Region Quickbase RESTful APIs - US Region Quickbase Sync - US Region Quickbase Webhooks - US Region
Update

05/06/2025, 09:46am EDT

05/06/2025, 09:46am EDT

Starting at 9:46 AM Eastern US Time, Quickbase US requests involving login, navigation, page refresh and rendering may be slower than normal.

We have identified the problem, applied a fix, and are monitoring performance.

We will post another update once performance has returned to normal.

Resolved

05/06/2025, 10:37am EDT

05/06/2025, 10:37am EDT

As of 10:37 AM Eastern US Time, the performance of Quickbase US has returned to normal.

This incident is closed.