[Quickbase EU Status] Notice: Product Patch (Planned) - No Down Time

Maintenance
05/19/2025, 03:50pm EDT

[Quickbase EU Status] Notice: Product Patch (Planned) - No Down Time

Status: closed
Start: 05/19/2025, 02:00pm EDT
End: 05/19/2025, 03:50pm EDT
Duration: 1 hour 50 minutes
Affected Components:
Quickbase Service - EU Region Quickbase Audit Logs - EU Region Quickbase Billing - EU Region Quickbase Pipelines - EU Region Quickbase RESTful APIs - EU Region Quickbase Sync - EU Region Quickbase Webhooks - EU Region
Update

05/19/2025, 02:00pm EDT

05/19/2025, 02:00pm EDT

Our journey to improve Quickbase and your product experience continues.  The Quickbase team will be performing planned maintenance to upgrade the Quickbase platform.  We do not expect any disruption to the Quickbase platform as we make these improvements.  For more information on the enhancements and bug fixes in this upgrade, check out the release notes.

This maintenance window will be: Monday, May 19, 2025 between 2:00 PM and 4:00 PM Eastern US Time.

Update

05/19/2025, 02:44pm EDT

05/19/2025, 02:44pm EDT

We are investigating issues related to this maintenance.  

Update

05/19/2025, 03:04pm EDT

05/19/2025, 03:04pm EDT

Between 2:39 PM and 3:04 PM Eastern US Time, the Quickbase EU platform was unavailable as a result of unexpected events during this maintenance window.

We've created a separate incident on the service page for the unplanned down time and will update that incident as we have more information.

We are continuing execution of this maintenance to upgrade the Quickbase EU platform and will update this incident once the maintenance is completed.

Resolved

05/19/2025, 03:50pm EDT

05/19/2025, 03:50pm EDT

The maintenance completed at 3:50 PM Eastern US Time.

Quickbase EU is operating normally.

This incident is closed.