[Quickbase Status] Notice: Service Functionality Degraded (Unplanned)

Incident
05/29/2025, 12:05pm EDT

[Quickbase Status] Notice: Service Functionality Degraded (Unplanned)

Status: closed
Start: 05/29/2025, 09:45am EDT
End: 05/29/2025, 11:30am EDT
Duration: 1 hour 45 minutes
Affected Components:
Quickbase Service - US Region Quickbase Audit Logs - US Region Quickbase Automations - US Region Quickbase Billing - US Region Quickbase Pipelines - US Region Quickbase Platform Analytics - US Region Quickbase RESTful APIs - US Region Quickbase Sync - US Region Quickbase Webhooks - US Region
Update

05/29/2025, 09:45am EDT

05/29/2025, 09:45am EDT

Starting at about 9:45 AM Eastern US Time, Automations performance is slow, and some Automations may be failing.  We are actively investigating.

Update

05/29/2025, 10:55am EDT

05/29/2025, 10:55am EDT

We are working on a fix and expect to deploy it within the next 10 minutes.

Update

05/29/2025, 11:10am EDT

05/29/2025, 11:10am EDT

We are deploying a fix and expect it to be completed within 20 minutes.

Resolved

05/29/2025, 11:30am EDT

05/29/2025, 11:30am EDT

As of 11:30 AM Eastern US Time, Automations are performing normally.

This incident is closed.

We will post a root cause once we have it.


Root Cause

05/29/2025, 12:05pm EDT

05/29/2025, 12:05pm EDT

We regularly apply security updates to all the software used by the Quickbase platform.  Between 9:45 AM and 10:00 AM Eastern US Time on May 29, we deployed updates to two software services that compose the Automations functionality used by some customers.  In addition to security updates, the deployment included a configuration change designed to improve the performance of the underlying computers supporting Automations.  An error in the configuration, that was not caught during our configuration review process, resulted in degraded performance.  We corrected the configuration issue and redeployed the two services used by Automations.  The redeployments completed by 11:30 AM Eastern US Time.  We are considering what changes can be made in our review process to catch the specific type of misconfiguration that occurred in this case.