[Quickbase Status] Notice: Service Unavailable (Unplanned) - Down Time

Incident
07/08/2025, 11:46am EDT

[Quickbase Status] Notice: Service Unavailable (Unplanned) - Down Time

Status: closed
Start: 07/08/2025, 11:25am EDT
End: 07/08/2025, 11:46am EDT
Duration: 21 minutes
Affected Components:
Quickbase University
Update

07/08/2025, 11:25am EDT

07/08/2025, 11:25am EDT

Quickbase uses a partner to host our online education platform - Quickbase University (university.quickbase.com). We are currently experiencing an issue where Quickbase University is not redirecting correctly to our education platform.  We are working with our partner to resolve as soon as possible.

There is no impact to the Quickbase platform where customer applications are hosted.

We will provide another update as soon as we have one.

Resolved

07/08/2025, 11:46am EDT

07/08/2025, 11:46am EDT

Quickbase University is now available again.  We apologize for the inconvenience.

This incident is closed.