[Quickbase Status] Notice: Service Functionality Degraded (Unplanned) - No Down Time

Incident
07/10/2025, 11:17am EDT

[Quickbase Status] Notice: Service Functionality Degraded (Unplanned) - No Down Time

Status: closed
Start: 07/10/2025, 10:20am EDT
End: 07/10/2025, 11:17am EDT
Duration: 57 minutes
Affected Components:
Quickbase Service - US Region Quickbase Service - EU Region Quickbase Audit Logs - US Region Quickbase Audit Logs - EU Region Quickbase Automations - US Region Quickbase Billing - EU Region Quickbase Pipelines - EU Region Quickbase Billing - US Region Quickbase Pipelines - US Region Quickbase RESTful APIs - EU Region Quickbase Sync - EU Region Quickbase Platform Analytics - US Region Quickbase RESTful APIs - US Region Quickbase Webhooks - EU Region Quickbase Sync - US Region Quickbase Webhooks - US Region
Update

07/10/2025, 10:20am EDT

07/10/2025, 10:20am EDT

We are investigating an issue where users may have been unable to save records on new forms and grid edit.   This is impacting both the US and EU instances.  We will provide an update as soon as we have one.

Resolved

07/10/2025, 11:17am EDT

07/10/2025, 11:17am EDT

We have deployed a fix for this issue. Saving records should return to normal behavior after a page refresh and clearing your browser's cache.

We will share a root cause analysis once we have it.

This incident is closed.