[Quickbase US Status] Notice: Product Upgrade (Planned) - No Down Time

Maintenance
08/19/2025, 07:01am EDT

[Quickbase US Status] Notice: Product Upgrade (Planned) - No Down Time

Status: closed
Start: 08/19/2025, 04:00am EDT
End: 08/19/2025, 07:01am EDT
Duration: 3 hours 1 minute
Affected Components:
Quickbase Service - US Region Quickbase Pipelines - US Region
Update

08/19/2025, 04:00am EDT

08/19/2025, 04:00am EDT

The Quickbase team will be performing maintenance to execute a minor upgrade of the Quickbase Pipelines service.  Some Pipelines may experience a short delay during this maintenance.

This maintenance window will be: Tuesday, August 19, 2025, between 4:00 AM and 5:00 AM Eastern US Time.

Update

08/19/2025, 05:30am EDT

08/19/2025, 05:30am EDT

We have identified minor issues with some Pipelines. We are actively working on a fix. We will post an update as soon as we have one.

Update

08/19/2025, 06:00am EDT

08/19/2025, 06:00am EDT

Our team is still actively working on resolving the issue. 

Update

08/19/2025, 06:30am EDT

08/19/2025, 06:30am EDT

The resolution of the identified issue will take longer than expected so to avoid further disruption of the Pipelines services, we have decided to revert the changes. We will post an update of the actual completion time as soon as possible.

Resolved

08/19/2025, 07:01am EDT

08/19/2025, 07:01am EDT

Due to release troubleshooting, the actual end time of this event was 7:00AM Eastern US Time