[Quickbase US Status] Notice: Service Functionality Degraded (Unplanned)

Incident
08/25/2025, 02:30pm EDT

[Quickbase US Status] Notice: Service Functionality Degraded (Unplanned)

Status: closed
Start: 08/10/2025, 08:40am EDT
End: 08/14/2025, 10:00am EDT
Duration: 4 days 1 hour 20 minutes
Affected Components:
Quickbase Service - US Region Quickbase Pipelines - US Region
Update

08/10/2025, 08:40am EDT

08/10/2025, 08:40am EDT

We are aware that some customers are experiencing rate-limiting errors when using Pipelines with QuickBooks. Our team is actively investigating the issue in collaboration with Intuit. We will share an update as soon as more information becomes available.

While investigating this issue, we have determined that it began at 8:40 AM Eastern US Time on Sunday, August 10.  It has become increasingly more impactful during the course of this week.

Update

08/14/2025, 09:25am EDT

08/14/2025, 09:25am EDT

Starting at 9:25 AM Eastern US Time, we are seeing a reduction in rate-limiting errors.  We are continuing to monitor the situation but impacted customers should check their QuickBooks pipelines to determine if they are working successfully.

Resolved

08/14/2025, 10:00am EDT

08/14/2025, 10:00am EDT

As of 10:00 AM Eastern US Time, QuickBooks pipelines are working properly.

This incident is closed.

We will post a root cause once we have it.

Root Cause

08/25/2025, 02:30pm EDT

08/25/2025, 02:30pm EDT

First, we realize we are an important part of your business, and you expect Quickbase to be available and performing well when you need it.  We apologize for the disruption that occurred as a result of this incident.  We have not met the standard you expect of us, or that we expect of ourselves.

We’ve completed our evaluation of this incident and provide the root cause below.

All times noted are Eastern US Time.

Our investigation ultimately determined, via log analysis, that the incident began on Sunday, August 10, at 8:40 AM.  The first reports from customers receiving the “Remote API is rate limited“ error from QuickBooks came on the morning of Monday, August 11.  Our monitoring did not detect this issue so we began to investigate it with the initial tech support cases from customers on Monday, and escalated to our Engineering department on Tuesday, August 12.  We investigated possible technical causes in our own software, and possible issues with Intuit QuickBooks Online, but found no reason why Intuit was blocking the requests.

On Thursday, August 14, we began investigating a possible link to an announcement Intuit communicated to their partners in May/June regarding changes Intuit was making in the treatment of API requests starting on August 1.

Starting on August 1, Intuit required all partners who make Intuit CorePlus API requests to QuickBooks to accept the terms and conditions of Intuit’s new partner program.  If a partner, Quickbase in this case, makes a total number of Intuit CorePlus API requests in excess of Intuit’s free billing plan entitlement for partners, with no overages allowed, the partner needed to sign up for Intuit’s Silver billing plan which includes a larger base entitlement of CorePlus API requests per month and charges the partner incrementally for any overages above the base entitlement of requests.

Quickbase received prior notice from Intuit in May/June announcing these new conditions for partners but we did not think these terms applied to us because we make our API requests to QuickBooks on behalf of our customers who already have their own agreements with Intuit for use of QuickBooks.  In hindsight, we misunderstood Intuit’s terms.  Intuit does not distinguish between API requests done directly by a partner to a QuickBooks account owned by the partner, and API requests done by a partner to QuickBooks accounts owned by specific Intuit customers.

As part of the Intuit partner changes, they provided partners with a dashboard that shows the total number of Intuit CorePlus API requests made each month.  While investigating on Thursday, August 14, we were able to determine that we hit the request limit of Intuit's free billing plan on Sunday, August 10, at 8:40 AM.  We then cross referenced that data with our own logs to confirm the root cause.

At 9:25 AM on August 14, we followed all the prescribed steps from Intuit which included signing up for their Silver billing plan.  Within minutes, we could see that CorePlus API requests were no longer being blocked, and by 10:00 AM, the QuickBooks Pipeline channel was operating normally.

As follow-up to this incident, we are working on improved monitoring that will allow us to more quickly detect when Intuit is rate limiting or blocking Intuit CorePlus API requests.  We’ve also clarified our role as an Intuit partner so we can avoid any future misunderstandings.