[Quickbase Status] Notice: Service Functionality Degraded (Unplanned) - No Down Time

Incident
09/30/2025, 01:36pm EDT

[Quickbase Status] Notice: Service Functionality Degraded (Unplanned) - No Down Time

Status: closed
Start: 09/30/2025, 11:37am EDT
End: 09/30/2025, 01:36pm EDT
Duration: 1 hour 59 minutes
Affected Components:
Quickbase Service - US Region Quickbase Service - EU Region Quickbase Platform Analytics - US Region Quickbase Platform Analytics - EU Region
Update

09/30/2025, 11:37am EDT

09/30/2025, 11:37am EDT

Our Platform Analytics platform is not functioning correctly. Some of the features, including downloads, are not fully operable. This is impacting both the US and EU instances.

We will provide an update as soon as one is available.

Resolved

09/30/2025, 01:36pm EDT

09/30/2025, 01:36pm EDT

We have deployed a fix for this incident. As of 1:36 PM Eastern US Time, Platform Analytics is working properly again.

This incident is closed.