[Quickbase Status] Notice: Service Functionality Degraded (Planned) - No Down Time

Incident
10/20/2025, 10:15pm EDT

[Quickbase Status] Notice: Service Functionality Degraded (Planned) - No Down Time

Status: closed
Start: 10/20/2025, 03:00pm EDT
End: 10/20/2025, 10:15pm EDT
Duration: 7 hours 15 minutes
Affected Components:
Quickbase Service - US Region Quickbase Service - EU Region Quickbase Audit Logs - US Region Quickbase Automations - US Region Quickbase Audit Logs - EU Region Quickbase Billing - US Region Quickbase Billing - EU Region Quickbase Pipelines - US Region Quickbase Pipelines - EU Region Quickbase Platform Analytics - US Region Quickbase Platform Analytics - EU Region Quickbase RESTful APIs - US Region Quickbase RESTful APIs - EU Region Quickbase Sync - US Region Quickbase Sync - EU Region Quickbase Webhooks - US Region Quickbase Webhooks - EU Region
Update

10/20/2025, 03:00pm EDT

10/20/2025, 03:00pm EDT

Certain components of the Quickbase platform are experiencing intermittent issues as a result of the ongoing AWS outage that has been widely publicized in the media today.  While the Quickbase platform is not directly hosted in the impacted region, the service Quickbase uses for setting the behavior of various features is impacted.  For example, new forms and Exchange app listings may fail to load reliably.  We're carefully monitoring the situation and will post an update as more information becomes available.

This issue is impacting both the Quickbase US and Quickbase EU instances of the platform.

Update

10/20/2025, 06:54pm EDT

10/20/2025, 06:54pm EDT

After further investigation, we have discovered specific services that are directly impacted by the AWS outage, not dependent on our feature flagging infrastructure. We're actively investigating potential ways to mitigate this impact.

We will post another update as soon as we have one.

Resolved

10/20/2025, 10:15pm EDT

10/20/2025, 10:15pm EDT

Performance for all Quickbase services has returned to normal.

This incident is closed.