[Quickbase Status] Notice: Quickbase University Unavailable (Unplanned) - Down Time

Incident
10/29/2025, 09:00pm EDT

[Quickbase Status] Notice: Quickbase University Unavailable (Unplanned) - Down Time

Status: closed
Start: 10/29/2025, 11:45am EDT
End: 10/29/2025, 04:51pm EDT
Duration: 5 hours 6 minutes
Affected Components:
Quickbase University
Update

10/29/2025, 11:45am EDT

10/29/2025, 11:45am EDT

As of 11:45 AM Eastern US Time, Quickbase University is unavailable.  We are investigating.

Resolved

10/29/2025, 04:51pm EDT

10/29/2025, 04:51pm EDT

As of 4:51 PM Eastern US Time, Quickbase University is available.

This incident is closed.

We will post a root cause once we have it.

Root Cause

10/29/2025, 09:00pm EDT

10/29/2025, 09:00pm EDT

Quickbase uses a partner to host our online education platform - Quickbase University (university.quickbase.com).  The partner's infrastructure runs on the Microsoft Azure service.  Starting at 11:45 AM Eastern US Time, Azure suffered a major outage resulting in many web sites going offline globally.  The outage also made it impossible for many web sites to switch to alternate locations.  Therefore, most web sites, including Quickbase University, were down until Microsoft could fix the underlying cause of the Azure outage.

At 4:51 PM Eastern US Time, Quickbase University was back online and functioning normally.

Microsoft has published a preliminary root cause here: https://azure.status.microsoft/en-us/status/history/

See the PIR titled "Preliminary Post Incident Review (PIR) - Azure Front Door - Connectivity issues across multiple regions" Tracking ID: YKYN-BWZ