[Quickbase Status] Notice: Service Functionality Degraded (Planned) - No Down Time

Maintenance
11/16/2025, 09:28am EST

[Quickbase Status] Notice: Service Functionality Degraded (Planned) - No Down Time

Status: closed
Start: 11/16/2025, 07:30am EST
End: 11/16/2025, 09:28am EST
Duration: 1 hour 58 minutes
Affected Components:
Quickbase Service - US Region Quickbase Audit Logs - US Region Quickbase Automations - US Region Quickbase Billing - US Region Quickbase Pipelines - US Region Quickbase Platform Analytics - US Region Quickbase RESTful APIs - US Region Quickbase Sync - US Region Quickbase Webhooks - US Region
Update

11/16/2025, 07:30am EST

11/16/2025, 07:30am EST

The Quickbase team will be performing planned maintenance to upgrade an internal database used to track customer accounts.  As part of the scheduled maintenance, the following will be intermittently unavailable:

  • Accessing and connecting to FastField from Quickbase
  • Account Summary Usage Tiles
  • Account Summary’s Explore Quickbase functionality

This maintenance window will be: Sunday, November 16, 2025 between 7:30 AM and 9:30 AM Eastern US Time.

Resolved

11/16/2025, 09:28am EST

11/16/2025, 09:28am EST

This incident is closed.