[Quickbase US Status] Notice: Service Functionality Degraded (Unplanned)

Incident
12/16/2025, 11:31pm EST

[Quickbase US Status] Notice: Service Functionality Degraded (Unplanned)

Status: closed
Start: 12/16/2025, 07:25pm EST
End: 12/16/2025, 11:31pm EST
Duration: 4 hours 6 minutes
Affected Components:
Quickbase Service - US Region Quickbase Sync - US Region
Update

12/16/2025, 07:25pm EST

12/16/2025, 07:25pm EST

Starting at 7:25 PM Eastern US Time, we are experiencing issues with the Box Connection for Sync. This is actively being investigated and worked on by Box.com.  We will post another update once performance has returned to normal.

Update

12/16/2025, 10:42pm EST

12/16/2025, 10:42pm EST

Box has released a fix. We continue to monitor. 

Resolved

12/16/2025, 11:31pm EST

12/16/2025, 11:31pm EST

Functionality has returned back to normal.