[Quickbase Status] Notice: Service Functionality Degraded (Unplanned)

Incident
12/18/2025, 10:08am EST

[Quickbase Status] Notice: Service Functionality Degraded (Unplanned)

Status: closed
Start: 12/18/2025, 07:51am EST
End: 12/18/2025, 10:08am EST
Duration: 2 hours 17 minutes
Affected Components:
Quickbase Service - US Region Quickbase Service - EU Region Quickbase Audit Logs - US Region Quickbase Automations - US Region Quickbase Audit Logs - EU Region Quickbase Billing - US Region Quickbase Billing - EU Region Quickbase Pipelines - US Region Quickbase Pipelines - EU Region Quickbase Platform Analytics - US Region Quickbase Platform Analytics - EU Region Quickbase RESTful APIs - US Region Quickbase RESTful APIs - EU Region Quickbase Sync - US Region Quickbase Sync - EU Region Quickbase Webhooks - US Region Quickbase Webhooks - EU Region
Update

12/18/2025, 07:51am EST

12/18/2025, 07:51am EST

Starting around 7:51 AM Eastern US Time, we are experiencing an issue with KPI reports displaying on application dashboards.

This issue appears to be specific to reports returning the value 0.  When encountering this issue, users are receiving this error:
"Unable to display widget"

This is impacting both the US and EU instances of the Quickbase platform.

Update

12/18/2025, 09:05am EST

12/18/2025, 09:05am EST

Our Development team has identified the issue and working on deploying a fix as soon as possible.

We will provide another update once we have one.

Resolved

12/18/2025, 10:08am EST

12/18/2025, 10:08am EST

A fix has been deployed.   We will provide a root case analysis once it's available.

This incident is closed.