[Quickbase EU Status] Notice: Product Upgrade (Planned) - No Down Time
Maintenance
12/18/2025, 01:11pm EST
[Quickbase EU Status] Notice: Product Upgrade (Planned) - No Down Time
Status: closed
Start:
12/18/2025, 01:00pm EST
End:
12/18/2025, 01:11pm EST
Duration: 11 minutes
Affected Components:
Quickbase Service - EU Region
Quickbase Sync - EU Region
Update
12/18/2025, 01:00pm EST
12/18/2025, 01:00pm EST
The
Quickbase team will be performing maintenance to execute a minor
upgrade of the Quickbase Sync service. Some customers with connected
tables may experience a delay of up to 15 minutes for scheduled
refreshes during this maintenance. Manual refreshes of connected tables
may fail at times during this maintenance. This maintenance window will be: Thursday, December 18, 2025, between 1:00 PM and 2:00 PM Eastern US Time.
Resolved
12/18/2025, 01:11pm EST
12/18/2025, 01:11pm EST
This incident is closed.