[Quickbase US Status] Notice: Infrastructure Maintenance (Planned) - No Down Time

Maintenance
01/16/2026, 09:16pm EST

[Quickbase US Status] Notice: Infrastructure Maintenance (Planned) - No Down Time

Status: closed
Start: 01/16/2026, 08:10pm EST
End: 01/16/2026, 09:16pm EST
Duration: 1 hour 6 minutes
Affected Components:
Quickbase Service - US Region Quickbase Audit Logs - US Region Quickbase Automations - US Region Quickbase Billing - US Region Quickbase Pipelines - US Region Quickbase Platform Analytics - US Region Quickbase RESTful APIs - US Region Quickbase Sync - US Region Quickbase Webhooks - US Region
Update

01/16/2026, 08:10pm EST

01/16/2026, 08:10pm EST

The Quickbase team will be performing planned maintenance to upgrade the disk storage for the database server cluster supporting the Quickbase US platform. 

During this maintenance window, there will be short periods where requests will be slower than normal, but we do not expect any disruption to the Quickbase platform.

This maintenance window will be: Friday, January 16, 2026, between 8:10 PM and 12:00 AM Eastern US Time.

Resolved

01/16/2026, 09:16pm EST

01/16/2026, 09:16pm EST

This incident is closed.