[Quickbase EU Status] Notice: Infrastructure Maintenance (Planned) - No Down Time

Maintenance
01/22/2026, 03:30pm EST

[Quickbase EU Status] Notice: Infrastructure Maintenance (Planned) - No Down Time

Status: closed
Start: 01/22/2026, 03:00pm EST
End: 01/22/2026, 03:30pm EST
Duration: 30 minutes
Affected Components:
Quickbase Service - EU Region Quickbase Audit Logs - EU Region Quickbase Billing - EU Region Quickbase Pipelines - EU Region Quickbase Platform Analytics - EU Region Quickbase RESTful APIs - EU Region Quickbase Sync - EU Region Quickbase Webhooks - EU Region
Update

01/22/2026, 03:00pm EST

01/22/2026, 03:00pm EST

The Quickbase team will be performing maintenance Thursday, January 22, between 3:00 PM and 4:00 PM Eastern US Time to update a component service of the Quickbase load balancer supporting the Quickbase EU platform.

We do not expect any disruption to the Quickbase platform as we make these improvements.

Resolved

01/22/2026, 03:30pm EST

01/22/2026, 03:30pm EST

This incident is closed.