[Quickbase Status] Notice: Service Functionality Degraded (Unplanned) - No Down Time

Incident
01/22/2026, 11:30pm EST

[Quickbase Status] Notice: Service Functionality Degraded (Unplanned) - No Down Time

Status: closed
Start: 01/22/2026, 02:00pm EST
End: 01/22/2026, 11:30pm EST
Duration: 9 hours 30 minutes
Affected Components:
Quickbase Service - US Region Quickbase Service - EU Region Quickbase Audit Logs - US Region Quickbase Automations - US Region Quickbase Audit Logs - EU Region Quickbase Billing - US Region Quickbase Billing - EU Region Quickbase Pipelines - US Region Quickbase Pipelines - EU Region Quickbase Platform Analytics - US Region Quickbase Platform Analytics - EU Region Quickbase RESTful APIs - US Region Quickbase RESTful APIs - EU Region Quickbase Sync - US Region Quickbase Sync - EU Region Quickbase Webhooks - US Region Quickbase Webhooks - EU Region
Update

01/22/2026, 02:00pm EST

01/22/2026, 02:00pm EST

Starting around 2 PM Eastern US Time, we are seeing an increase in delayed emails sent from the Quickbase platform to any Microsoft Office email provider recipient.  This issue is caused by an incident acknowledged by Microsoft and not an issue with the Quickbase platform.  

Microsoft is working on fixing this issue as soon as possible.

We will continue to monitor this incident and will provide an update as soon as we have one.

Resolved

01/22/2026, 11:30pm EST

01/22/2026, 11:30pm EST

As of 10:34 PM Eastern US Time, email delivery from the Quickbase platform to recipients using Microsoft Office has returned to normal. Emails triggered during the incident will continue to be retried and delivered automatically.

This incident is closed.