[Quickbase Status] Notice: Service Functionality Degraded (Unplanned) - No Down Time

Incident
02/09/2026, 04:05pm EST

[Quickbase Status] Notice: Service Functionality Degraded (Unplanned) - No Down Time

Status: closed
Start: 02/09/2026, 08:48am EST
End: 02/09/2026, 04:05pm EST
Duration: 7 hours 17 minutes
Affected Components:
Quickbase University
Update

02/09/2026, 08:48am EST

02/09/2026, 08:48am EST

We are experiencing an issue with logging in and accessing Quickbase University (university.quickbase.com) - our online training curriculum platform.  We are engaged with the hosting provider to fix this as soon as possible.  There is no impact to the Quickbase platform that hosts Quickbase applications.

We apologize for the inconvenience and will provide an update as soon as we have one.

Update

02/09/2026, 09:31am EST

02/09/2026, 09:31am EST

Our hosting provider has acknowledged the issue on their end and are working to fix as soon as possible.

We will provide another update as soon as we have one. 

Update

02/09/2026, 12:54pm EST

02/09/2026, 12:54pm EST

Our hosting provider continues to work on this issue.  We will provide another update as soon as we have one.

Resolved

02/09/2026, 04:05pm EST

02/09/2026, 04:05pm EST

Our hosting provider has deployed a fix.  We will provide a root cause once it's available. 

This incident is closed