[Quickbase US Status] Notice: Infrastructure Maintenance (Planned) - No Down Time

Maintenance
02/18/2026, 08:04pm EST

[Quickbase US Status] Notice: Infrastructure Maintenance (Planned) - No Down Time

Status: closed
Start: 02/18/2026, 08:00pm EST
End: 02/18/2026, 08:04pm EST
Duration: 4 minutes
Affected Components:
Quickbase Service - US Region Quickbase RESTful APIs - US Region
Update

02/18/2026, 08:00pm EST

02/18/2026, 08:00pm EST

The Quickbase team will be performing maintenance to execute a minor update of the SSL certificate used in the US instance of the Quickbase RESTful API service. No impact is expected during this maintenance.

This maintenance window will be: Wednesday, February 18, 2026, between 8:00 PM and 8:30 PM Eastern US Time.

Resolved

02/18/2026, 08:04pm EST

02/18/2026, 08:04pm EST

This incident is closed.