[Quickbase US Status] Notice: Product Upgrade (Planned) - No Down Time

Maintenance
02/25/2026, 09:00pm EST

[Quickbase US Status] Notice: Product Upgrade (Planned) - No Down Time

Status: closed
Start: 02/25/2026, 08:00pm EST
End: 02/25/2026, 09:00pm EST
Duration: 1 hour
Affected Components:
Quickbase Service - US Region Quickbase Automations - US Region
Update

02/25/2026, 08:00pm EST

02/25/2026, 08:00pm EST

The Quickbase team will be performing maintenance to execute a minor upgrade of the Quickbase AI console and related features. 

This maintenance window will be Wednesday, February 25, 2026, between 8:00 PM to 9:00 PM Eastern US Time.

Users may encounter a generic error message when accessing the following services:

Product Help

AI Report Suggestions

AI Spreadsheet Import

AI NLQ Report

AI App Documentation

AI App Generation (Smart Builder)

Resolved

02/25/2026, 09:00pm EST

02/25/2026, 09:00pm EST

This incident is closed.