[Quickbase US Status] Notice: Service Functionality Degraded (Unplanned) - No Down Time

Incident
02/24/2026, 02:33pm EST

[Quickbase US Status] Notice: Service Functionality Degraded (Unplanned) - No Down Time

Status: closed
Start: 02/24/2026, 01:53pm EST
End: 02/24/2026, 02:33pm EST
Duration: 40 minutes
Affected Components:
Quickbase Service - US Region Quickbase Audit Logs - US Region Quickbase Automations - US Region Quickbase Billing - US Region Quickbase Pipelines - US Region Quickbase Platform Analytics - US Region Quickbase RESTful APIs - US Region Quickbase Sync - US Region Quickbase Webhooks - US Region
Update

02/24/2026, 01:53pm EST

02/24/2026, 01:53pm EST

Between 1:53 PM and 2:33 PM Eastern US Time, some custom email notifications experienced delays or failed to send. This issue affected notifications sent through custom emails. Legacy email notifications including record change notifications, report subscriptions, and reminders were not impacted.

The issue was caused by a temporary outage affecting an external email delivery provider used by Quickbase. The provider has since identified and resolved the issue, and normal email delivery resumed as of 2:33 PM EST.

We apologize for any inconvenience this may have caused.

Resolved

02/24/2026, 02:33pm EST

02/24/2026, 02:33pm EST

This incident is closed.