[Quickbase US Status] Notice: Service Functionality Degraded (Unplanned) - No Down Time

Incident
03/12/2026, 04:00am EDT

[Quickbase US Status] Notice: Service Functionality Degraded (Unplanned) - No Down Time

Status: in progress
Start: 02/26/2026, 08:00pm EST
Affected Components:
Quickbase Service - US Region Quickbase Audit Logs - US Region Quickbase Automations - US Region Quickbase Billing - US Region Quickbase Pipelines - US Region Quickbase Platform Analytics - US Region Quickbase RESTful APIs - US Region Quickbase Sync - US Region Quickbase Webhooks - US Region
Update

02/26/2026, 08:00pm EST

02/26/2026, 08:00pm EST

Since about 8:00 PM Eastern US Time on Thursday, February 26th, some e-mails to Microsoft consumer inboxes (e.g., outlook.com, live.com, hotmail.com, msn.com) from the Quickbase US platform are being blocked by Microsoft.

The majority of Quickbase US customers do not use Microsoft's free e-mail service and hence are not impacted by this issue.

We apologize for the negative impact this issue is having on some customers and doing everything we can to resolve it.

We are actively working with Microsoft and our e-mail delivery vendor to remove the block on our e-mails.

Update

03/11/2026, 06:47pm EDT

03/11/2026, 06:47pm EDT

As of 6:47 PM Eastern US Time, Microsoft has implemented mitigations for the blocks and we are beginning to see improvement in delivery to Microsoft consumer customers.

Update

03/12/2026, 04:00am EDT

03/12/2026, 04:00am EDT

We continue to see e-mail delivery improve to Microsoft consumer customers. Nearly all e-mail to Microsoft customers is now being delivered normally. We are actively working with Microsoft and our e-mail delivery vendor to improve and monitor the issue.