[Quickbase Status] Notice: Quickbase Help Service Functionality Degraded (Unplanned)
Incident
03/16/2026, 10:20am EDT
[Quickbase Status] Notice: Quickbase Help Service Functionality Degraded (Unplanned)
Status: closed
Start:
03/16/2026, 10:00am EDT
End:
03/16/2026, 10:20am EDT
Duration: 20 minutes
Affected Components:
Quickbase Help
Update
03/16/2026, 10:00am EDT
03/16/2026, 10:00am EDT
We are experiencing performance issues accessing Quickbase Help (help.quickbase.com). Our hosting provider has acknowledged the issue on their end and are are working to fix this as soon as possible. There is no impact to the Quickbase platform that hosts Quickbase applications.
We will provide another update as soon as we have one.
Resolved
03/16/2026, 10:20am EDT
03/16/2026, 10:20am EDT
Quickbase Help is performing normally again. We will provide a root cause once it's available.
This incident is closed.