[Quickbase Status] Notice: Service Functionality Degraded (Planned) - No Down Time

Incident
03/17/2026, 01:29pm EDT

[Quickbase Status] Notice: Service Functionality Degraded (Planned) - No Down Time

Status: closed
Start: 03/17/2026, 10:23am EDT
End: 03/17/2026, 01:29pm EDT
Duration: 3 hours 6 minutes
Affected Components:
Quickbase Service - US Region Quickbase Service - EU Region Quickbase Fastfield - US Region Quickbase Fastfield - EU Region
Update

03/17/2026, 10:23am EDT

03/17/2026, 10:23am EDT

Starting at 10:23 AM Eastern US Time, authentication (login) attempts to the Quickbase US or Quickbase EU platforms from Fastfield are failing.  In addition, direct calls to the FastField API services are also impacted at this time.

We are actively investigating this issue and will post an update by 11:45 AM Eastern US Time.

Update

03/17/2026, 11:42am EDT

03/17/2026, 11:42am EDT

We are implementing a solution for the issue.  We will post another update by 12:15 PM Eastern US Time.

Update

03/17/2026, 11:59am EDT

03/17/2026, 11:59am EDT

As of 11:55 AM Eastern US Time, direct calls to the Fastfield API services are working.  We are still investigating the authentication issue between Fastfield and the QB platform.  We will post another update by 12:30 PM Eastern US Time.

Resolved

03/17/2026, 01:29pm EDT

03/17/2026, 01:29pm EDT

As of 12:45 PM Eastern US Time, authentication (login) between Fastfield and the Quickbase platforms (US and EU) is working.

This incident is closed.

We will post a root cause once we have it.