[Quickbase Status] Notice: Quickbase University Service Functionality Degraded (Unplanned) - No Down Time

Incident
03/20/2026, 09:37am EDT

[Quickbase Status] Notice: Quickbase University Service Functionality Degraded (Unplanned) - No Down Time

Status: closed
Start: 03/20/2026, 09:10am EDT
End: 03/20/2026, 09:37am EDT
Duration: 27 minutes
Affected Components:
Quickbase University
Update

03/20/2026, 09:10am EDT

03/20/2026, 09:10am EDT

We are experiencing an issue with accessing the content in Quickbase University (university.quickbase.com) - our online training curriculum platform. We are working with our hosting provider to fix the issue as soon as possible. There is no impact to the Quickbase platform that hosts Quickbase applications. 

We apologize for the inconvenience and will provide an update as soon as we have one.

Resolved

03/20/2026, 09:37am EDT

03/20/2026, 09:37am EDT

Quickbase University is working properly again. We will provide RCA once we have it from our hosting provider.  

This incident is closed.