[Quickbase Status] Notice: Quickbase Help Service Functionality Degraded (Unplanned)

Incident
04/02/2026, 04:37am EDT

[Quickbase Status] Notice: Quickbase Help Service Functionality Degraded (Unplanned)

Status: closed
Start: 04/01/2026, 06:56am EDT
End: 04/01/2026, 09:58am EDT
Duration: 3 hours 2 minutes
Affected Components:
Quickbase Help
Update

04/01/2026, 06:56am EDT

04/01/2026, 06:56am EDT

We are experiencing performance issues accessing Quickbase Help (help.quickbase.com). Our hosting provider has acknowledged the issue on their end and are are working to fix this as soon as possible.  There is no impact to the Quickbase platform that hosts Quickbase applications.

We will provide another update as soon as we have one.

Resolved

04/01/2026, 09:58am EDT

04/01/2026, 09:58am EDT

Quickbase Help is performing normally again.  We will provide a root cause once it's available.

This incident is closed.

Update

04/02/2026, 04:37am EDT

04/02/2026, 04:37am EDT

This issue was caused by an unexpected increase in traffic that temporarily impacted the Quickbase Help site (help.quickbase.com). Our hosting provider quickly identified the issue and put protections in place to stabilize traffic. Performance returned to normal shortly after. Our hosting provider has created additional monitoring and safeguards to help prevent this kind of disruption in the future.