[Quickbase US Status] Notice: Service Functionality Degraded (Emergency) - Down Time

Maintenance
04/27/2026, 10:30pm EDT

[Quickbase US Status] Notice: Service Functionality Degraded (Emergency) - Down Time

Status: closed
Start: 04/27/2026, 10:00pm EDT
End: 04/27/2026, 10:30pm EDT
Duration: 30 minutes
Affected Components:
Quickbase Service - US Region Quickbase Community Quickbase University Quickbase Audit Logs - US Region Quickbase Fastfield - US Region Quickbase Automations - US Region Quickbase Billing - US Region Quickbase Pipelines - US Region Quickbase Platform Analytics - US Region Quickbase RESTful APIs - US Region Quickbase Sync - US Region Quickbase Webhooks - US Region
Update

04/27/2026, 10:00pm EDT

04/27/2026, 10:00pm EDT

The Quickbase team will be performing emergency maintenance to upgrade a database that supports logins between the Quickbase US platform and the following related Quickbase systems:

  • FastField (only impacts FastField customers who directly connect to the Quickbase US platform via single sign-on)
  • Juiced Cloud (only impacts Juiced customers who directly connect to the Quickbase US platform via single sign-on)
  • Quickbase's Support Portal (for customers entering and viewing support cases)
  • Quickbase Community
  • Quickbase University

We expect that new logins between the Quickbase US platform and the systems listed above may fail for up to 2 minutes during this maintenance window.  Existing sessions, i.e., customer is already logged in, should not be impacted.

This maintenance window will be: Monday, April 27, 2026, between 10:00 PM and 10:30 PM Eastern US Time.

Resolved

04/27/2026, 10:30pm EDT

04/27/2026, 10:30pm EDT

This incident is closed.