[Quickbase Status] Notice: Service Functionality Degraded (Unplanned)
Incident
06/11/2026, 08:32pm EDT
[Quickbase Status] Notice: Service Functionality Degraded (Unplanned)
Status: closed
Start:
06/10/2026, 01:55pm EDT
End:
06/11/2026, 08:32pm EDT
Duration: 1 day 6 hours 37 minutes
Affected Components:
Quickbase Service - US Region
Quickbase RESTful APIs - US Region
Update
06/10/2026, 01:55pm EDT
06/10/2026, 01:55pm EDT
Between Wednesday, June 10 at 1:55 PM and Thursday, June 11 at 8:32 PM Eastern US Time, a subset of the Quickbase REST API service (api.quickbase.com) experienced slow performance or returned HTTP 502 or 524 errors. The Quickbase team took corrective action and the service returned to normal operation on Thursday, June 11 at 8:32 PM Eastern US Time.
Resolved
06/11/2026, 08:32pm EDT
06/11/2026, 08:32pm EDT
This incident is closed.