[Quickbase Status] Notice: Quickbase Community Unavailable (Unplanned) - Down Time

Incident
06/17/2026, 09:24pm EDT

[Quickbase Status] Notice: Quickbase Community Unavailable (Unplanned) - Down Time

Status: closed
Start: 06/17/2026, 08:03pm EDT
End: 06/17/2026, 09:24pm EDT
Duration: 1 hour 21 minutes
Affected Components:
Quickbase Community
Update

06/17/2026, 08:03pm EDT

06/17/2026, 08:03pm EDT

As of 8:03 PM Eastern US Time, the Quickbase Community is unavailable. We are actively investigating.

Resolved

06/17/2026, 09:24pm EDT

06/17/2026, 09:24pm EDT

Our hosting provider has deployed a fix for this issue and the Quickbase Community is working properly again.

This incident is closed.