[Quickbase Status] Notice: Quickbase Extensions Portal Maintenance (Planned) - Down Time

Maintenance
07/14/2026, 10:15am EDT

[Quickbase Status] Notice: Quickbase Extensions Portal Maintenance (Planned) - Down Time

Status: closed
Start: 07/13/2026, 11:00pm EDT
End: 07/13/2026, 11:26pm EDT
Duration: 26 minutes
Affected Components:
Quickbase Service - US Region Quickbase Extensions - US Region
Update

07/13/2026, 11:00pm EDT

07/13/2026, 11:00pm EDT

To improve the security and reliability of the Quickbase Extensions Portal, we will be conducting scheduled maintenance from 11:00 PM Eastern US Time on Monday, July 13, 2026, until 1:00 AM Eastern US Time on Tuesday, July 14, 2026.

During this maintenance window, you may experience intermittent outages, errors, or other unexpected behavior while accessing the Extensions Portal. We recommend avoiding use of the Portal during this time.

Following the maintenance, the Extensions Portal will be available at a new URL: https://portal.extensions.quickbase.com

Requests made to the previous URL, https://extensions.quickbase.com, will continue to be automatically redirected to the new address until August 12th.

Please update existing bookmarks, saved links, or cached references to use the new URL before that date.

Resolved

07/13/2026, 11:26pm EDT

07/13/2026, 11:26pm EDT

This incident is closed.

Root Cause

07/14/2026, 10:15am EDT

07/14/2026, 10:15am EDT

This change has been reverted as of 10:15 AM Eastern US Time on Tuesday, July 14, 2026.

The Extensions Portal is again available via https://extensions.quickbase.com.

Following the migration, for the web versions of Quickbase Extensions, users were receiving errors saying "Error occurred : Response status code does not indicate success: 405 (Method Not Allowed).", resulting in nothing being displayed. Documents were still generated and uploaded into file attachments.

Once a new date and time have been selected for the migration, a new post to the Quickbase Service Page will be created.