[Pave Status] Notice: Service Functionality Degraded (Unplanned)

Incident
07/31/2026, 10:44am EDT

[Pave Status] Notice: Service Functionality Degraded (Unplanned)

Status: closed
Start: 07/31/2026, 09:54am EDT
End: 07/31/2026, 10:44am EDT
Duration: 50 minutes
Affected Components:
Quickbase Pave - US Region
Update

07/31/2026, 09:54am EDT

07/31/2026, 09:54am EDT

As of 9:54 AM Eastern US Time, Pave is experiencing degraded performance. We are actively investigating.

Resolved

07/31/2026, 10:44am EDT

07/31/2026, 10:44am EDT

The Pave team has implemented a fix for the issue and as of 10:44 AM Eastern US Time, Pave is back online. Users may have been unable to access Pave apps between 10:12 and 10:44 AM Eastern US Time.

The Pave team is actively investigating the root cause and will provide more information as it becomes available.