[Quickbase Status] Notice: Quickbase University Functionality Degraded (Unplanned) - No Down Time

Incident
08/05/2026, 07:55am EDT

[Quickbase Status] Notice: Quickbase University Functionality Degraded (Unplanned) - No Down Time

Status: closed
Start: 08/03/2026, 05:24am EDT
End: 08/03/2026, 06:41am EDT
Duration: 1 hour 17 minutes
Affected Components:
Quickbase University
Update

08/03/2026, 05:24am EDT

08/03/2026, 05:24am EDT

We are experiencing an issue with logging in and accessing Quickbase University (university.quickbase.com) - our online training curriculum platform.  Our hosting provider has acknowledged the issue on their end and are are working to fix this as soon as possible.  There is no impact to the Quickbase platform that hosts Quickbase applications.

We apologize for the inconvenience and will provide an update as soon as we have one.

Resolved

08/03/2026, 06:41am EDT

08/03/2026, 06:41am EDT

Our hosting provider has deployed a fix for this issue and Quickbase University is working properly again.  


This incident is closed. 

Update

08/05/2026, 07:55am EDT

08/05/2026, 07:55am EDT

The issue was caused by a change implemented by our vendor that unexpectedly impacted authentication to QB University. Once the issue was identified, the vendor rolled back the change, restoring normal service. We confirmed with the vendor improvements to change validation and monitoring are in place to reduce the risk of similar issues occurring in the future.

There was no impact to the Quickbase platform that hosts our customers' applications.  The issue was specific to QB University only.