[Quickbase EU Status] Notice: Product Upgrade (Planned) - No Down Time

Maintenance
08/19/2026, 09:11am EDT

[Quickbase EU Status] Notice: Product Upgrade (Planned) - No Down Time

Status: closed
Start: 08/19/2026, 09:00am EDT
End: 08/19/2026, 09:11am EDT
Duration: 11 minutes
Affected Components:
Quickbase Service - EU Region Quickbase Sync - EU Region
Update

08/19/2026, 09:00am EDT

08/19/2026, 09:00am EDT

The Quickbase team will be performing maintenance to execute a minor upgrade of the Quickbase Sync service.  Some customers with connected tables may experience a delay of up to 15 minutes for scheduled refreshes during this maintenance.  Manual refreshes of connected tables may fail at times during this maintenance.  Some owners of Salesforce connections may need to reauthorize their connection after this release.

This maintenance window will be: Wednesday, August 19, 2026, between 9:00 AM and 10:00 AM Eastern US Time.

Resolved

08/19/2026, 09:11am EDT

08/19/2026, 09:11am EDT

This incident is closed.