[Quickbase US Status] Notice: Service Functionality Degraded (Planned) - No Down Time

Incident
08/28/2026, 10:00am EDT

[Quickbase US Status] Notice: Service Functionality Degraded (Planned) - No Down Time

Status: closed
Start: 08/28/2026, 07:15am EDT
End: 08/28/2026, 10:00am EDT
Duration: 2 hours 45 minutes
Affected Components:
Quickbase Service - US Region Quickbase Pipelines - US Region
Update

08/28/2026, 07:15am EDT

08/28/2026, 07:15am EDT

Starting around 7:15 AM Eastern US Time, a subset of Pipelines are experiencing a delay in execution.  We are actively working on this issue to fix as soon as possible.  We will provide an update as soon as we have one.

Update

08/28/2026, 08:15am EDT

08/28/2026, 08:15am EDT

We have identified the issue and are working to restore service back to normal operations as soon as possible.

Update

08/28/2026, 09:15am EDT

08/28/2026, 09:15am EDT

We are continuing to work on this issue impacting a subset of Pipeline executions.  We will provide another update as soon as we have one. 

Update

08/28/2026, 09:49am EDT

08/28/2026, 09:49am EDT

We have deployed a fix and are seeing an improvement in performance.  We are continuing to monitor and will provide another update as soon as we have one.

Resolved

08/28/2026, 10:00am EDT

08/28/2026, 10:00am EDT

All Pipelines are back to performing normally again.  We apologize for any inconvenience this issue has caused.  We will provide a root cause analysis once it's available.

This incident is closed.