[Quickbase US Status] Notice: Service Functionality Degraded (Unplanned) - No Down Time

Incident
09/01/2026, 11:29am EDT

[Quickbase US Status] Notice: Service Functionality Degraded (Unplanned) - No Down Time

Status: closed
Start: 08/31/2026, 03:15pm EDT
End: 08/31/2026, 04:59pm EDT
Duration: 1 hour 44 minutes
Affected Components:
Quickbase Service - US Region Quickbase Pipelines - US Region
Update

08/31/2026, 03:15pm EDT

08/31/2026, 03:15pm EDT

We are currently investigating an issue where a subset of Pipelines are experiencing a delay in triggering.  We will provide an update as soon as we have one. 

Update

08/31/2026, 04:13pm EDT

08/31/2026, 04:13pm EDT

We've identified the issue and are deploying a fix.  We will provide another update as soon as we have one.

Resolved

08/31/2026, 04:59pm EDT

08/31/2026, 04:59pm EDT

All Pipelines are performing normally again.  All previously delayed Pipelines have been triggered.  There was no data loss with this incident.

We will provide a root cause once we have it.

Root Cause

09/01/2026, 11:29am EDT

09/01/2026, 11:29am EDT

A recent configuration change caused a spike in demand on a backend service responsible for triggering Pipelines.  That service didn't scale to meet the demand as designed, resulting in delayed Pipeline triggers for a subset of executions. We corrected the configuration change, restoring trigger times back to normal, while also completing all previously delayed Pipelines.

We've added additional monitoring to prevent this issue from reoccurring.

We apologize for the inconvenience this issue has caused.