[Quickbase EU Status] Notice: Service Functionality Degraded (Unplanned)

Incident
09/04/2026, 05:15am EDT

[Quickbase EU Status] Notice: Service Functionality Degraded (Unplanned)

Status: closed
Start: 09/04/2026, 03:05am EDT
End: 09/04/2026, 05:15am EDT
Duration: 2 hours 10 minutes
Affected Components:
Quickbase Service - EU Region Quickbase Audit Logs - EU Region Quickbase Platform Analytics - EU Region
Update

09/04/2026, 03:05am EDT

09/04/2026, 03:05am EDT

Starting around 3:05 AM Eastern US Time, a provider incident is affecting our logging. Audit Logs and Platform Analytics may be impacted. We are actively working with the provider to resolve this issue as soon as possible and will provide an update as soon as we have one.

Update

09/04/2026, 05:00am EDT

09/04/2026, 05:00am EDT

Our team is still investigating. Will post an update as soon as we have one.

Resolved

09/04/2026, 05:15am EDT

09/04/2026, 05:15am EDT

The provider has resolved the incident, and our platform operations are back to normal. During the impacted timeframe, customers may have experienced issues accessing Audit Logs and Platform Analytics. There was no data loss, and everything has been fully restored.